MY CAMERA WON'T WORK!!

posted November 25th, 2010
i am stumped, and so frustrated. my nikon d90 has an error reading 'r21' and nothing i've done seems to fix it. i've switched lenses, memory cards, batteries...still getting the reading. i've googled it and haven't found much help. does anyone know what this means? and more importantly, how to fix it? your help is MUCH APPRECIATED, as i sure would like to have my camera for the holiday tomorrow!! thank you in advance...
posted November 25th, 2010
Sorry Brett , no idea, but I hope you can get it sorted out too
posted November 25th, 2010
i never confess to be a camera genius...did bing it for you though. found 2 discussion threads on flicker that seem to have the answer. has something to do with how many shots are left before the buffer is full... not sure if this will help you at all.... here are the links!!

http://www.flickr.com/groups/nikon_d90/discuss/72157614517531804/
http://www.flickr.com/groups/nikon_d90_users/discuss/72157615762999838/
posted November 25th, 2010
I have a d70s and I don't know how different it is. That code is not in the manual but there is a little paragraph that I'll quote:
"In rare instances, unusual characters may appear in the control panel and the camera may stop functioning. In most cases, this phenomenon is caused by a strong external static charge. Turn the camera off, remove and replace the battery, and turn the camera on again. If the problem persists, press the reset switch and then reset the camera clock to the correct date and time." The reset switch is a tiny circle you push in on the bottom of the camera - looking at the bottom of the camera with the lens pointing up it is at the top right corner.

Your camera may be way different than the d70 but I thought I'd give it a try. Good luck!
posted November 25th, 2010
I know I sometimes get a r12 on my D300, and it's because the aperture ring on my 50mm gets unlocked and moves out of place. If I put the ring back in proper place, and lock it, code goes away.

But when I google that code, I get the nonsense about buffer space left... but the issue is with my 50mm lens so ??? Haha, sometimes google makes no sense, so maybe start looking for really weird things... knobs, buttons, etc out of place. You did mention multiple lenses, so it might not be similar to my problem, though.

Is it saying FEE where the aperture would be showing? If so, it might be an aperture ring issue like mine, and you need to move it to the highest aperture (F22 or above) and lock it in place.
posted November 25th, 2010
@andiejaye , Thanks for the links, and after reading these responses, it makes me realize that that has happened to me a lot.... after awhile it will work again... and take shots.. I thought it was my batteries dying.... now I know... thank you Andie..
Brett hope this is the simple answer to your problem..
posted November 25th, 2010
thanks to you all for caring and trying to help! i really appreciate it, ladies. still no luck, sadly.

@andiejaye thanks for the links! i had seen those when i googled the issue as well, and i think that if it is JUST the buffer, i should still be able to take photos--so i think it must be something more...):
@pfmandeville thanks for looking it up for me--not sure how similar they are, but i had tried removing the battery/grip and have reset all the settings with still no luck! ):
@hmgphotos i saw similar responses about the aperture ring--but unfortunately my lenses don't have this (they are 'g' lenses, whatever that means). i did try to change the aperture anyway, just in case, but it is still locked up.
posted November 25th, 2010
Its not in the manual? (Not trying to be a jerk) Someone mentioned it being on/around page 65. Have you tried taking whatever photos are on your memory card off, and using a blank one? (or even just trying a different one?)

posted November 25th, 2010
You've probably figured this out already, but the 'r21' is not an error, it's how many shots the camera camera can buffer. (meaning your camera can store photos internally before they're written to the card to allow you to shoot more frames per second than your camera is able to write them to the card) You'll see this r21 when you press the shutter down half way. If you were to shoot 15 photos at 5fps, then immediately hold the shutter down half way, you'd see that it's at around r7 then it'll slowly count up until it gets back to r21.

If I were having the issue, here's the steps I'd take. (attempt to take a photo between each step - you can stop troubleshooting once you can take a photo again)
1. Set the focusing switch on the front of the camera body to M instead of AF.
2. Try putting on a different lens. If the chip in the lens is passing bad information to the camera it's possible for it to prevent the camera from taking a shot.
3. Change out the CF card and format the replacement card in camera (hold down the two red format buttons)
4. If you've got a vertical grip, remove it.
5. Charge the battery -- even if it's showing up as full, throw it on a charger for a few hours, then put it back in.
6. Set the camera to Manual, Shutter or Aperture mode. (just make sure it's not in one of the scene modes.)
7. go into the menus and reset your shooting menu and your custom setting menu.
Good Luck
posted November 25th, 2010
LOL, ignore what I said, I'm just a retard :) I never realized, in my 4 years of using a DSLR, that it says Rxx when you half push the shutter normally. LOL!! I'm usually not looking at the top of my LCD obviously, and don't stare at the right hand corner of the viewfinder. My issues with aperture rings is the FEE thing, and just happens that I see r12 at the same thing.

*goes back to my corner and shuts up*

At least I learned something, haha.
posted November 25th, 2010
@crappysailor i think the pg 65 reference was for a different model; the d90 only has an online manual, and yes, i've checked it with no new info. ): tried different memory cards, batteries, lenses, all.
@sudweeks yes, i know the r21 is a buffer issue, except i'm also getting an 'error' message with that. and i cannot depress the shutter all the way to take a picture. so, will try your steps (though i've tried many of them already) in that order and see if i can get success!! thanks!
@hmgphotos ha! and thanks for trying though! (:
posted November 25th, 2010
@bcurrie - Lenses too huh? Because my girlfriends camera was having an issue with errors and focusing. All that was need was to clean the contact points. Hmm, this is annoying huh?

Please let us know what you find out.
posted November 25th, 2010
@crappysailor will do; planning on calling nikon tomorrow (HOPING they are open!)
Write a Reply
Sign up for a free account or Sign in to post a comment.